Wednesday, 21 January 2009

Install Subversion under RedHat Enterprise Linux4

This morning I tried to install Subversion 1.5.1 on Red Hat Enterprise Linux 4. This turned out to be a slightly more complicated than just easy. Because I ran into some dependency issues.

I downloaded Subversion 1.5.1 at: http://summersoft.fay.ar.us/pub/subversion/1.5.1/rhel-4/i386/.

Running rpm gave me the following depencency issues:

rpm -ihv subversion-1.5.1-1.i386.rpm
error: Failed dependencies:
apr >= 0.9.7 is needed by subversion-1.5.1-1.i386
apr-util >= 0.9.7 is needed by subversion-1.5.1-1.i386
libneon.so.27 is needed by subversion-1.5.1-1.i386
neon >= 0.26.1 is needed by subversion-1.5.1-1.i386

To solve this download the following libraries:
Summerset is one of the suppliers of the subversion binaries. I found that they did quite a good job on providing the necessary libraries for the different Linux flavors. At least the ones I needed. However, although subversion 1.5.1 needed the arp libraries, they were not found in the subversion/1.5.1/rhel-4 folder. So I fetched them from the subversion/1.4.6/rhel-4 folder.

Since subversion needed a specific neon-shared-object, I could not do it in one go, because at dependency check the system-object was not there. Therefor I first installed neon and neon-devel:

rpm -ihv neon-0.27.2-1.i386.rpm neon-devel-0.27.2-1.i386.rpm
Preparing... ########################################### [100%]
1:neon-devel ########################################### [ 50%]
2:neon ########################################### [100%]

Then the rest could be installed in one go:
rpm -Uhv subversion-1.5.1-1.i386.rpm apr-0.9.12-2.i386.rpm apr-util-0.9.12-1.i386.rpm
Preparing... ########################################### [100%]
1:apr ########################################### [ 33%]
2:apr-util ########################################### [ 67%]
3:subversion ########################################### [100%]

So I now start off with creating my repository.

6 comments:

Tingting said...

Thanx for your guide - I had to go through a bit more to get it all done. Here is my sequence of things to do - note that I actually had to dump a few devel packages.

wget http://summersoft.fay.ar.us/pub/subversion/1.5.5/rhel4/i386/subversion-1.5.5-1.i386.rpm
wget http://summersoft.fay.ar.us/pub/subversion/1.5.5/rhel4/i386/apr-0.9.12-2.i386.rpm
wget http://summersoft.fay.ar.us/pub/subversion/1.5.5/rhel4/i386/apr-util-0.9.12-1.i386.rpm
wget http://summersoft.fay.ar.us/pub/subversion/1.5.5/rhel4/i386/neon-0.27.2-1.i386.rpm
wget ftp://rpmfind.net/linux/fedora/releases/7/Everything/i386/os/Fedora/compat-db-4.3.29-2.fc7.i386.rpm
wget ftp://rpmfind.net/linux/fedora/releases/7/Everything/i386/os/Fedora/compat-openldap-2.3.34_2.2.29-0.fc7.i386.rpm
wget ftp://rpmfind.net/linux/fedora/releases/7/Everything/i386/os/Fedora/openldap-2.3.34-0.fc7.i386.rpm
rpm -e openldap-devel-2.3.27-8.el5_2.4.i386 apr-util-devel-1.2.7-7.el5.i386
rpm -ivh *.rpm

Fritz said...

useful stuff.

Just for completeness, if anyone reading this gets the error 'file /usr/lib/libapr-0.so.0 from install of apr-0.9.12-2 conflicts with file from package apr-0.9.4-24.9' or similar, you need to run rpm with the --force option, i.e.
rpm -ih --force apr-0.9.12-2.i386.rpm (and so forth for the other packages)

Erich said...

This did the trick for me!

Thank you

V-Teq said...

Thank you for this post. It saved me at least an half of hour of my life.

Lisa said...

Hi,
The urls that you mentioned in your post (very, very helpful btw) have changed slightly. Here is the new and correct url:
http://summersoft.fay.ar.us/pub/subversion/1.5.5/rhel4/i386/

Ralph Lauren said...

Thanks for the guide! Very usefull